Java EE 6 (Servlet & JSP) Maven dependency

publikováno: 17.5.2013

V Java EE 6 je:

  • Servlet 3.0
  • JSP 2.2

Abyste měli při vývoji v classpath třídy jako je HttpServletRequest, přidejte do pom.xml tyto závislosti:

<dependency>
<groupId>javax.servlet</groupId>
<artifactId>javax.servlet-api</artifactId>
<version>3.0.1</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>javax.servlet.jsp</groupId>
<artifactId>javax.servlet.jsp-api</artifactId>
<version>2.2.1</version>
<scope>provided</scope>
</dependency>

Následující:
HTML parser v Javě
Reference

Líbilo se mi celé pojetí kurzu - možná trošku netradiční, nicméně dělané ajťákem pro ajťáky. :-) ("normální" člověk, který by se na kurzu náhodou ocitl, by asi nechápal). Vše bylo

Martin

Školení pro nás bylo velice přínosné. Ocenil jsem zejména konzultace vhodnosti použití přímo nad reálnými problémy v našem projektu. Výklad byl plně customizovaný našim potřebám a znalostem. Celkově velká spokojenost.

Jiří

Školení se mi opravdu líbilo. Jako vždy bylo vidět, že pan Pinkas se v dané oblasti dobře orientuje a ví jak se Docker používá v praxi. Vysvětlení pojmů vždy prijde

Zdeněk


Novinky

9.5.2019: Plánovaný přechod Java EE -> Jakarta EE
Posledních několik měsíců intenzivně sleduji plánovaný přechod z Java EE na Jakarta EE. A musím říct, že to je shit-show :-(

22.3.2019: Termíny Java školení léto 2019
Nové termíny!!!

22.3.2019: Vyšla Java 12!
Java 12 je venku!!!