Maven compiler plugin

publikováno: 12.6.2013

Jak vynutit kompilaci kódu pomocí určité verze Javy? Pokud chcete, aby byl Váš kód zkompilován pod Java 7, pak přidejte do pom.xml do tagu <plugins> tento plugin:

<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId>
    <version>3.1</version>
    <configuration>
        <source>1.7</source>
        <target>1.7</target>
    </configuration>
</plugin>

 

Reference

Jedno z nejlepších školení za poslední roky. Kromě seznámení se Springem apod. mě velmi příjemně překvapila hluboká znalost probírané látky a schopnost ji srozumitelně vysvětlit v případě ad hoc dotazů.

Jaroslav

Velmi jsem oceňoval různorodost školení a široký záběr z java světa + schopnost rychle reagovat na všechny otázky, ať se týkaly jakéhokoliv tématu v Javě. Také se mi líbili různé

Marek

uvolnena atmosfera. nekdo by si mozna myslel, ze az moc, ale mne to tak vyhovuje a paradoxne pomaha k soustredeni :) no a spousta zajimavosti, preci jen je citit, kdyz s

Vojtěch


Novinky

20.10.2019: Don't Put Fat Jars in Docker Images: Optimalizace

20.10.2019: Spring Boot 2.2.0!!!

20.10.2019: JDBC Driver Maven dependency list: Oracle drivery jsou v Maven Central!!!