Maven Enforcer Plugin

publikováno: 29.8.2013

Maven Enforcer Plugin slouží k vynucení parametrů buildovacího prostředí (jako je verze Mavenu a Javy, typ operačního systému a další). Standardně se spouští v build fázi Mavenu "validate", která je jako úplně první fáze, která se spouští: http://maven.apache.org/ref/3.1.0/maven-core/lifecycles.html

Abyste například vynutili, že je nutné aplikaci buildovat pouze na Windows, přidejte toto do pom.xml:

<plugin>
   <groupId>org.apache.maven.plugins</groupId>
   <artifactId>maven-enforcer-plugin</artifactId>
   <version>1.3.1</version>
   <executions>
      <execution>
         <id>enforce-versions</id>
         <goals>
            <goal>enforce</goal>
         </goals>
         <configuration>
            <rules>
               <requireOS>
                  <family>windows</family>
               </requireOS>
            </rules>
         </configuration>
      </execution>
   </executions>
</plugin>

 

Reference

Splnilo to mé očekávání si zopakovat základy Spring framework. Je vidět že školení je dobře připravené, že tomu co školíte rozumíte, že vás to baví, vysvětlíte principy a je dobře

Petr

Podavane informace byly aktualni, byly vysvetlene i souvislosti, hlavne na uvod byl dobre vysvetlen kontext probiraneho tematu, teda co je co a jaky to ma vyznam. Navic bylo cele skoleni podporeno

Petr

Líbily se mi "informační odskoky" k jiným knihovnám (např. Lombok), pro lidi zakonzervované 100 let na jednom projektu osvěžující.

Vojtěch


Novinky

20.2.2019: JIB 1.0

20.2.2019: Amazon Corretto 11
Amazon Corretto 11 je venku!

7.2.2019: Docker + Raspberry Pi + Java
Jak použít OpenJDK 11+ na Raspberry Pi s Dockerem